installa l'estensione php intl sul leone di montagna

Sto cercando di installare Rubedo cms e get un errore nell'applicazione php:

Zend\I18n\Validator component requires the intl PHP extension 

Questi sono i passaggi che ho preso per installare l'estensione

 sudo port install php5-intl sudo cp /opt/local/lib/php54/extensions/no-debug-non-zts-20100525/intl.so /usr/lib/php/extensions/no-debug-non-zts-20090626/ sudo pico /private/etc/php.ini 

Inserisci

 extension=intl.so 

poi

 sudo apachectl restart 

Ho trovato il problema.

Avevo bisogno della versione giusta di intl. Sto eseguendo php 5.3, che penso sia la ragione per cui quando ho eseguito:

 sudo port install php53-intl 

ha funzionato.

Significativamente, anche la cartella principale è stata identificata nello src e nella destinazione nella copia.

Quindi il mio process finale è stato:

 sudo port install php53-intl sudo cp /opt/local/lib/php54/extensions/no-debug-non-zts-20090626/intl.so /usr/lib/php/extensions/no-debug-non-zts-20090626/ sudo pico /private/etc/php.ini 

Inserisci

 extension=intl.so 

poi

 sudo apachectl restart 

Usa Brew .

es. brew install php56-intl

Questo è tutto! 🙂