# 1193 – Variabile di sistema sconosciuta 'lc_messages' quando si tenta di accedere a phpmyadmin

Ho recentemente installato mysql e phpmyadmin l'ho già fatto ma sono passati molti anni per qualche motivo quando provo ad accedere a phpmyadmin con le credenziali di root ottengo questo errore Error

Query SQL: Modifica Modifica

SET lc_messages = 'en_US';

MySQL ha detto: Documentazione

1193 – Variabile di sistema sconosciuta 'lc_messages'

Ho cercato su Internet cercando una soluzione, ma non riesco a trovare nessun altro in questo preciso problema. Qualcuno può aiutarmi a capire perché sto vedendo questo errore

Ho affrontato lo stesso problema. Controlla la tua versione mySQL:

Per mySQL 5.5, utilizzare phpMyAdmin 4.4.xe versioni successive

Per mySQL 5.1, utilizzare phpMyAdmin 4.0.x

Spero che questo aiuti qualcuno.

Ho avuto lo stesso problema ed ecco come l'ho risolto:

  1. MySql aggiornato alla versione più recente: http://www.tecmint.com/install-latest-mysql-on-rhel-centos-and-fedora/

  2. Dopo l'aggiornamento non è stato ansible avviare il servizio mysql. Ecco la soluzione:
    mysqld_safe –skip-grant-tables
    mysql_upgrade

Ho scoperto che avevo una versione precedente di phpmyadmin e l'errore era dovuto a una modifica apportta a PHP 7.

Se esegui una qualsiasi versione di php 5.5 o superiore riceverai questo errore se non aggiorni phpmyadmin.

Disinstallare la tua versione di mysql e tutte le dependencies. Per vedere tutti i tuoi pacchetti mysql e dependencies installate prova questo command:

- rpm -qa | grep mysql 

Per la disinstallazione:

 - yum erase mysql - yum erase mysqlPackageDependencie ... 

Quando tutte le dependencies vengono disinstallate, installa la nuova versione di mysql:

 - yum install mysql55-server 

Avvia il tuo servizio Mysql:

 - service mysqld start 

Grande! Tutto funziona perfettamente ora! 🙂